Service Manager / Sage 300 Version Compatibility


Our version compatibility and upgrade path is based on these general rules:
  • Service Manager versions are consistent with Sage 300 version numbers. i.e. versions must always be identical. E.g. 2016 for Sage 300 2016 and so forth.
    Occasionally we do release a “B” version that will work with the same version of Sage. e.g. 6.0A and 6.0B will work with Sage 300 6.0A.
  • If you are using a version of  Service Manager earlier than 5.3A, you must upgrade to either 5.3A, 5.3B, 5.4A or 5.5A before upgrading to 5.6A or later 

Please note support for 6.0A and 6.0B has been discontinued in line with Sage Support Policy N-2 (where N is the current version)
Copyright © 2016 Technisoft Pty Ltd. All rights reserved. Legals